PHP8 content类二次开发升级说明

更新时间:2021-03-10 加入收藏

从4.3.13版开始支持PHP8,如果之前版本二次开发过php文件,需要按照本教程来对应的升级兼容代码。

二次开发过php文件的情况是指:安装官方文档写的或者新建的php文件、自己写的或者新建的php文件,都属于二次开发范围


在使用老版本的方法时系统会提醒异常:

->save()方法已经失效,请改为->save_content()


Content类(/dayrui/Fcms/Model/Content.php)升级

适用于内容发布使用,火车头采集接口发布,等等,只要是自己写过发布内容的代码都需要改进

找的原有的代码

$rt = $this->content_model->save(0, $value);

以上代码是老版本的写法

改为新方法

$rt = $this->content_model->save_content(0, $value);

就是把save方法改成save_content方法


帮助文档首页
关注DiYunCMS公众号
公众号二维码
Hello,欢迎来咨询~
点击在线咨询